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EXCEL CHAPTER 12:  TEMPLATES, STYLES, AND MACROS
Available Instructor Resources
	Resource
	File Name
	Found

	Student Data Files
	various
	Online Instructor Resource Center

	Solution Files
	various
	Online Instructor Resource Center 

	Answer Keys 
	 
	Online Instructor Resource Center 

	      Matching
	e12_answerkey_match
	

	      Multiple Choice
	e12_answerkey_mc
	 

	      Concepts Checks
	e12_answerkey_concepts
	 

	Scorecards
	e12b1Tips_scorecard
	Online Instructor Resource Center 

	Scoring Rubrics
	e12b1Tips_rubric
	Online Instructor Resource Center 

	Annotated Solution File
	e12b1Tips_annsolution
	Online Instructor Resource Center 

	Scripted Lecture (Script)
	e12_script
	Online Instructor Resource Center 

	    Scripted Lecture Solution
	e12_script_solution
	

	    Scripted Lecture Data
	e12_script_data
	 

	PowerPoint Presentation
	e12_powerpoints
	Online Instructor Resource Center 

	Testbank
	e12_testbank
	Online Instructor Resource Center 

	Instructor's Manual (lesson plans incl.)
	e12_instructormanual
	Online Instructor Resource Center 

	Assignment Sheet
	e12_assignsheet
	Online Instructor Resource Center 

	Prepared Exam (Chapter & App)
	 
	Online Instructor Resource Center 

	      Prepared Exam-Chap instruction
	e12_exam_chap_instruction
	

	      Prepared Exam-Chap solution
	e12_exam_chap_solution
	

	      Prepared Exam-Chap Data
	e12_exam_chap_data
	

	      Prepared Exam-Chap Annotated Sol.
	e12_exam_chap_annsolution
	

	      Prepared Exam-Chap Scorecard
	e12_exam_chap_scorecard
	

	      Prepared Exam-App instruction
	e12_cumexam_instruction
	 

	      Prepared Exam-App solution
	e12_cumexam_solution
	 

	      Prepared Exam-App Data
	e12_cumexam_data
	 

	      Prepared Exam-App Annotated Sol.
	e12_cumexam_annsolution
	 

	      Prepared Exam-App scorecard
	e12_cumexam_scorecard
	 

	File Guide
	e12_file_guide
	Online Instructor Resource Center 

	Instructor Resource Card
	e12_ircard
	Online Instructor Resource Center 

	Objective Map
	e12_objectivesmap
	Online Instructor Resource Center 

	Online Chapter Review
	e12_chapt_checklist
	Companion Website for Students

	Grader Project
	 
	 

	       Grader-instruction
	e12_grader_instruction
	Online Instructor Resource Center 

	       Grader-solution
	e12_grader_solution
	

	       Grader-data
	e12_grader_data
	

	       Grader-annoted. Solution
	e12_grader_annsolution
	 

	       Grader-scorecard
	e12_grader_scorecard
	 

	Additional Projects (Practice & Mid Level)
	 
	Online Instructor Resource Center 

	       Additional Proj-Practice instruction
	e12_p_addproject_instruction
	

	       Additional Proj- Practice solutions
	e12_p_addproject_solution
	

	       Additional Proj-Practice Data
	e12_p_addproject_data
	

	       Additional Proj-Practice Ann Sol.
	e12_p_addproject_annsolution
	

	       Additional Proj-Practice Scorecard
	e12_p_addproject_scorecard
	

	       Additional Proj-Mid Level instruction
	e12_ml_addproject_instruction
	 

	       Additional Proj-Mid Level solutions
	e12_ml_addproject_solution
	

	       Additional Proj-Mid Level Data
	e12_ml_addproject_data
	

	       Additional Proj-Mid Level Ann Sol.
	e12_ml_addproject_annsolution
	 

	       Additional Proj-Mid Level Scorecard
	e12_ml_addproject_scorecard
	 



CHAPTER OBJECTIVES 
When students have finished reading this chapter, they will be able to:

· Select a template
· Apply themes and backgrounds
· Apply cell styles
· Create and use a template
· Protect a cell, a worksheet, and a workbook
· Create a macro
· Create macro buttons
· Set macro security
· Create a sub procedure
· Create a custom function




CHAPTER OVERVIEW
The major sections in this chapter are:
Templates, Themes, and Styles: Selecting a template; applying themes and backgrounds; applying cell styles 
Custom Templates and Workbook Protection: Creating and using a template; protecting a cell, a worksheet, and a workbook
Macros: Creating a macro; creating macro buttons; setting macro security
Visual Basic for Applications: Creating a sub procedure; creating a custom function

CLASS RUNDOWN
1. Have students turn in homework assignments.
2. Talk about chapter using discussion questions listed below. 
3. Use PowerPoint presentation to help students understand chapter content.
4. Demonstrate Excel 2013.
5. Run through Scripted Lectures for chapter.
6. Have students complete Capstone Exercise for Excel Chapter 12.
7. Use MyITLab for in-class work or to go over homework.
8. Give students Homework Handout for next class period. 

LEARNING OBJECTIVES
At the end of this lesson students should be able to:

· Select a template
· Apply a theme
· Apply a background
· Apply cell styles
· Unlock input cells
· Protect the worksheet
· Save the workbook as a template
· Use the template to create a sample weekly time sheet report
· Display the Developer tab
· Record a macro
·  Run a macro
· Add a macro button
· Create a sub procedure 
· Edit a macro
· Assign a macro to an image
· Create a custom function
KEY TERMS
Chapter X: Title	
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Background – An image that appears behind the worksheet data onscreen; it does not print.
Cell style – A set of formatting options applied to worksheet cells to produce a consistent appearance for similar cells within a worksheet.
Comment – Documents programming code; starts with an apostrophe and appears in green in the VBA Editor.
Keyword – A special programming syntax used for a specific purpose; appears in blue in the VBA Editor.
Locked cell – A cell that prevents users from making changes to that cell in a protected worksheet.
Macro – A set of instructions that tells Excel which commands to execute.
Macro Recorder – A tool that records a series of commands in the sequence performed by a user and converts the commands into programming syntax. 
Module – A VBA module is a file the stores sub procedures and functions. Modules can be created and viewed in the VBA Editor.
Object – A variable that contains both data and code and represents an element of Excel. 
Personal Macro Workbook – A hidden workbook stored in the XLStart folder that contains macros and opens automatically when you start Excel.
Procedure – A named sequence of statements that execute as one unit.
Run time error – A software or hardware problem that prevents a program from working correctly.
Sub procedure – Command lines written in the VBA Editor that have the ability to perform actions in Excel.
Template – A special workbook file used as a model to create similarly structured workbooks.
Theme – A collection of colors, fonts, and special effects.
Visual Basic Editor – The Office application used to create, edit, execute, and debug macros using programming language.
Visual Basic for Applications (VBA) – The office application used to create, edit, execute, and debug macros using programming language.
DISCUSSION QUESTIONS
· The chapter mentions security issues that may arise when using macros. Ask students to discuss these terms, and then research on the Web how these concerns have been addressed by various entities. 
· How would you explain to an employer the value of using macros, and how you would address his/her security concerns? 
· What are the inherent issues with trusting documents with active content?
WHEN USING SCRIPTED LECTURE IN CLASS, DEMONSTRATE HOW TO:
· Select a template
· Apply a theme
· Apply a background
· Apply cell styles
· Unlock input cells
· Protect the worksheet
· Save the workbook as a template
· Use the template to create a sample weekly time sheet report
· Display the Developer tab
· Record a macro
· Run a macro
· Add a macro button
· Create a sub procedure
· Edit a macro
· Assign a macro to an image
· Create a custom function

CONNECTIONS PRACTICAL PROJECTS AND APPLICATIONS
· Have students create a personal budget template, using their own income and expenses. 
· Have students practice creating macros for a personal budget template or other workbook to be shared with other users, and then create documentation for how to run the macros for others. 

TEACHING NOTES
Templates, Themes, and Styles

Excel has the tools to improve productivity in developing consistently formatted workbooks. 
A. Selecting a Template
· Color can be a good way to increase interest in your worksheet—but use care, as it can also be distracting. The same is true for images in a worksheet—for instance, pictures behind your data can make it hard to read. 
· Adding borders to areas on your spreadsheet can help emphasize that information. Use it sparingly, however—too many boxes on a page can be confusing. 
· Teaching Tip: Any Microsoft Office user has the ability to submit personally created templates to Office.com. If when searching you discover several templates with the name Travel Expense Report, be sure to select the option that resembles the image in Figure 12.7. If you are unable to locate the required template, a copy of the file e12h1ExpenseReport is included with the start files for this chapter. 
B. Applying Themes and Backgrounds
· Enlarging a font size on a spreadsheet isn’t just a screen attribute—it will print that size, too. If you need to see things better on the screen, it’s probably better to use the Zoom tool rather than increase the font size. 
· Teaching Tip: You can turn off the gridlines to increase the visibility of the background image and the worksheet data. Click the Page Layout tab and deselect the Gridlines View check box in the Sheet Options group.
· Teaching Tip: To delete a background picture, click Delete Background in the Page Setup group on the Page Layout tab.
C. Applying Cell Styles
· Teaching Tip: When you create your own cell styles, the styles are saved with the workbook in which you created the styles. However, you may want to apply those styles in other workbooks as well. To do this, open the workbook that contains the custom cell styles (the source) and open the workbook in which you want to apply those custom styles (the destination). In the destination workbook, click Cell Styles in the Styles group on the Home tab. Select Merge Styles at the bottom of the Cell Styles gallery to open the Merge Styles dialog box. In the Merge styles from list, select the name of the workbook that contains the styles you want and click OK. When you click Cell Styles again, the custom styles appear in the gallery.
Custom Templates and Workbook Protection

While using Excel templates can save time, they may not always fit your needs. A custom template can be used as a model for identically structured workbooks. 
A. Creating and Using a Template
· Users may have templates that they created in earlier versions of Excel—but Excel 2013 (as in other applications in Office) does not display them by default. Microsoft has a Fix it to migrate the custom office templates folder, which will do all of the Office 2013 programs at the same time, or you can do it yourself—doing it yourself allows you to control the location where the files will be stored. You can obtain the Fix it by visiting Microsoft’s website.
· There are many custom templates available online, including templates from Microsoft. Discuss the potential hazards or risks involved with using a custom template from a source other than Microsoft, and how you can mitigate those risks. 
· Teaching Tip: Formulas used in workbooks display zeros or error messages when you remove values to create a template. You can use the IFERROR function to check a cell to see if it contains errors or if a formula will result in an error. If no error exists, the IFERROR function returns the value of the formula. You can enter an argument in the function to display a customized error message instead of a default error, such as #DIV/0! In addition, you can set validation rules so template users will enter correct data.
· Teaching Tip: Templates use a different file extension (.xltx) than Excel workbooks (.xlsx). In order for your template to appear in the Template gallery in the Backstage view, be sure to save it in the correct folder, C:\Users\username\Documents\CustomOfficeTemplates in Windows 8 and Windows 7. If you use File Explorer to find the Templates folder, you will need to display hidden folders to do so. If you save your custom templates in the correct location, you can use them to create new workbooks by clicking the File tab, clicking New, and then clicking Personal in the Templates gallery of the Backstage view. The New dialog box displays thumbnails and names for the templates you created.
B. Protecting a Cell, a Worksheet, and a Workbook
· Teaching Tip: Alternatively, after selecting a cell or range of cells to unlock, you can open the Format Cells dialog box, click the Protection tab, deselect the Locked check box, and then click OK.
· Teaching Tip: Passwords can be up to 255 characters, including letters, numbers, and symbols. Passwords are case sensitive, so passWORD is not the same as Password. Make sure you record your password in a secure location or select a password that you will always remember. If you forget the password, you will not be able to unprotect the worksheet.
· Teaching Tip: To unprotect a workbook, click the Review tab, click Protect Workbook, type the password in the Password box in the Unprotect Workbook dialog box, and then click OK.
· Teaching Tip: If you unlock too many cells, select the cells that should be locked, click Format, and then select Lock Cell to lock them again.
· Teaching Tip: If you are allowed to enter the new value without the warning box, the cell is not locked. Click Undo to restore the formula, review how to unlock cells, and then lock this cell.
· Teaching Tip: When saving a template, Excel changes the file location to C:\Users\Username\My Documents\CustomOfficeTemplates. Students may not have the ability to save a template to the hard drive of your school’s computer lab, or you may request students to submit the file. To ensure students do not lose the template, they need to be sure to change the save location to their student data folder. Note that if they do change the default location, the template will not display in the Personal template gallery and they will need to manually open the file from their student data folder to continue.
· Teaching Tip: If students were not able to save the template to the Custom Office Templates folder, they will not see the template in the Personal template gallery. If this is the case, the file can be located by searching Recent Workbooks from the Open menu in the Backstage view.
Macros

A macro is a set of instructions that execute a sequence of commands to automate repetitive or routine tasks. 
A. Creating a Macro
· Teaching Tip: You cannot append a macro using the macro recorder. Additional steps can only be added using the VBA Editor; however, writing new programming code takes time to learn. Until you are comfortable adding a lot of commands to a macro, you can create a temporary macro, record the commands you need, and then copy the code in the VBA Editor and paste it in the appropriate location in the primary macro code.
· Teaching Tip: The default Store macro in setting is This Workbook. If you want to create a macro that is available in any Excel workbook, click the Store macro in arrow and select Personal Macro Workbook. This option creates Personal.xlsb, a hidden Personal Macro Workbook containing the macro in the C:\Users\Username\AppData\Roaming\Microsoft\Excel\XLStart folder within Windows 8 and Windows 7. Workbooks stored in the XLStart folder open automatically when you start Excel. When the Personal Macro workbook opens, the macros in it are available to any other open workbook.
· Teaching Tip: If you no longer need a macro, use the Macro dialog box to select the macro and click Delete. Excel will prompt you with a message box asking if you want to delete the selected Macro. Click Yes to confirm the deletion.
B. Creating Macro Buttons
· Excel hides the Developer tab by default. There are many tools on this tab that users may want to access. To display the Developer tab, use the dropdown on the Quick Access Toolbar. Choose More Commands, then in the left pane, choose Customize Ribbon. In the Customize the Ribbon list, check Developer, and then click OK. 
· Teaching Tip: You can insert other controls in a worksheet such as images and artwork and then assign macros to them. For example, you can insert combo boxes, check boxes, and option buttons by clicking Insert in the Controls group on the Developer tab and selecting the desired control. Drag an area on the worksheet to draw the control, right-click the object, and then select Assign Macro to assign a macro action for that particular control.
C. Setting Macro Security
· Discuss with students what they need to know about sharing workbooks that contain macros via email. Macros are active content, and can make the Message Bar with a security warning appear. 
· Teaching Tip: If students do not see Templates in Recent Places, they can click Open and navigate to the local directory that contains their student files. 
· Teaching Tip: Encourage students to read through the steps for creating a macro in advance before they proceed. Remember most actions taken in Excel are recorded by the macro recorder. Practice the steps before activating the recorder. If they make a major mistake, they can delete the macro and repeat the steps. 
· Teaching Tip: Make sure students select Excel Macro-Enabled Template, not Excel Macro-Enabled Workbook, because they want the file saved as a template, not a workbook. Because the template contains macros, students must save it as an Excel Macro-Enabled Template, not just a template.
Visual Basic for Applications

Visual Basic for Applications is a robust programming language that can be used within various software packages to enhance and automate functionality. 
A. Creating a Sub Procedure
· You can use the VBE to create a “splash screen” for an Excel workbook—a splash screen displays when the workbook is opened and disappears automatically after a specific time has elapsed. 
B. Creating a Custom Function
· VBA code appears in different colors to differentiate various types of text—you can adjust these colors if you really want to.
· 

ONLINE CHAPTER REVIEW
To find an online chapter review to help your students practice for tests, visit the Companion Website at http://www.pearsonhighered.com/exploring/.
ADDITIONAL WEB RESOURCES
1. What's new in Excel 2013—http://office.microsoft.com/en-us/excel-help/what-s-new-in-excel-2013-HA102809308.aspx
2. Online Excel Help—www.mrexcel.com  
3. Microsoft Tech Support—http://support.microsoft.com/ 

PROJECTS AND EXERCISES
	
	Data file
	Save As

	Hands-On Exercise 1
	e12h1Map.jpg, e12h1ExpenseReport.xltx 
	e12h1ExpenseReport_LastFirst.xlsx

	Hands-On Exercise 2
	e12h1ExpenseReport_LastFirst .xlsx
	e12h2ExpenseReport_LastFirst.xlsx, e12h2ExpenseReportTemplate_LastFirst.xltx, e12h2Sample_LastFirst.xlsx

	Hands-On Exercise 3
	e12h2ExpenseReportTemplate_LastFirst.xltx
	e12h3ExpenseReportTemplate_LastFirst.xltm

	Hands-On Exercise 4
	e12h3ExpenseReportTemplate_LastFirst.xltm, e12h4Calendar.png
	e12h4ExpenseReportTemplate_LastFirst.xltm

	Practice Exercise 1
	e12p1Bpressure.jpg
	e12p1BpTracker_LastFirst.xltx

	Practice Exercise 2
	e12p2Doctors.xlsx
	e12p2Doctors_LastFirst.xlsm

	Mid-Level Exercise 1
	e12m1Pirates.xlsx, e12m1Pirate.jpg, e12m1Baseball.jpg
	e12m1Pirates_LastFirst.xlsx, e12m1Baseball_LastFirst.xltx, e12m1Broncos_LastFirst.xlsx

	Mid-Level Exercise 2
	e12m2Airport.xlsx
	e12m2Airport_LastFirst.xlsm

	Mid-Level Exercise 3
	e12m3FundRaiser.xlsx
	e12m3FundRaiser_LastFirst.xlsx

	BYC 2 Research
	e12h3ExpenseReportTemplate_LastFirst.xltm 
	e12b2Trust_LastFirst.docx

	BYC 3 Disaster Recovery
	e12b3RealEstate.xlsm
	e12b3RealEstate_LastFirst.xlsm

	BYC 4 Collaboration
	 
	e12b4Evaluation_LastFirst.xlsx

	Capstone 
	e12c1Schedule.xlsx, e12c1Office.xlsx
	e12c1Schedule_LastFirst.xltm, e12c1InfoSys_LastFirst.xlsm, e12c1InfoSys_LastFirst.xltm, e12c1Office_LastFirst.xlsm



CHAPTER REVIEW/ANSWERS TO END OF CHAPTER MATERIAL

Key Terms Matching Answer Key

1. 	A Template (N) is a special workbook file used as a model to create similarly structured workbooks.
2. 	A Theme (O) is a collection of colors, fonts, and special effects.
3. 	A Background (A) is an image that appears behind the worksheet data onscreen; it does not print.
4. 	Cell style (B) is a set of formatting options applied to worksheet cells.
5. 	A Locked cell (E) prevents users from making changes to a specific cell in a protected worksheet.
6 	A Macro (F) is a set of instructions that tells Excel which commands to execute.
7. 	The Macro Recorder (G) is a tool that records a series of commands in the sequence performed by a user and converts the commands into programming syntax.
8. 	A Personal Macro Workbook (J) is a hidden workbook stored in the XLStart folder that contains macros and opens automatically when you start Excel.
9. 	Visual Basic Editor (Q) is the Office application used to create, edit, execute, and debug macros using programming language.
10. 	A Procedure (K) is a named sequence of statements that can be executed by the user or a macro.
11. 	A Keyword (D) is a special programming syntax used for a specific purpose that appears in blue in the Visual Basic Editor.
12. 	A Comment (C) documents programming code, starts with an apostrophe, and appears in green in the VBA Editor.
13. 	A Sub procedure (M) is command lines written in the VBA Editor that have the ability to perform actions in Excel.
14. 	A Module (H) is a file that stores sub procedures and functions. 
15. 	An Object (I) is a variable that contains both data and code and represents an element of Excel.
16.	 A Run time error (L) is a software or hardware problem that prevents a program from working correctly.
17. 	Visual Basic for Applications (P) is a robust programming language that can be used within various software packages to enhance and automate functionality.
Multiple Choice Answer Key
1. Which would you do to start using a calendar template from Office.com Templates?
(b) Open the Backstage view, click New, and then click Calendars in the Suggested Searches options. 
2. You created an invoice template to prepare invoices for your consulting business. In Windows 8, where would you save the template so it is available in the available templates list in the Backstage view? 
(c) C:\Users\username\Documents\CustomOfficeTemplates
3. Your company just had a new corporate logo designed. What do you do in Excel to present professional-looking reusable workbooks to share with clients?
(d) All of the above
4. How do you print a background image?
(d) Backgrounds are not printable
5. What is the keyboard shortcut to access the VBA Editor?
(d) Alt+F11
6. If you forget the password you used to protect an Excel worksheet, how do you reset it?
(a) You cannot reset it.
7. In which programming language are Excel macros written?
(c) VBA
8. When you get ready to write a macro:
(a) Be careful and thorough as you plan which actions to record so you do not inadvertently record unnecessary steps.
9. Which of the following statements is true about macro security?
(b) Setting your Trust Center options to include files in a specific folder and then saving macro-enabled files in that folder allows you to open those files with the content enabled.
10. Which of the following Workbook file extensions support macros?
[bookmark: _GoBack](d) All of the above
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