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EXCEL CHAPTER 4: Datasets and Tables: Managing Large Volumes of Data
Available Instructor Resources
	Resource
	File Name
	Found

	Student Data Files
	various
	Online Instructor Resource Center

	Solution Files
	various
	Online Instructor Resource Center 

	Answer Keys 
	 
	Online Instructor Resource Center 

	      Matching
	e04_answerkey_match
	

	      Multiple Choice
	e04_answerkey_mc
	 

	      Concepts Checks
	e04_answerkey_concepts
	 

	Scorecards
	e04b1Tips_scorecard

	Online Instructor Resource Center 

	Scoring Rubrics
	e04b1Tips_rubric
	Online Instructor Resource Center 

	Annotated Solution File
	e04b1Tips_annsolution
	Online Instructor Resource Center 

	Scripted Lecture (Script)
	e04_script
	Online Instructor Resource Center 

	    Scripted Lecture Solution
	e04_script_solution
	

	    Scripted Lecture Data
	e04_script_data
	 

	PowerPoint Presentation
	e04_powerpoints
	Online Instructor Resource Center 

	Testbank
	e04_testbank
	Online Instructor Resource Center 

	Instructor's Manual (lesson plans incl.)
	e04_instructormanual
	Online Instructor Resource Center 

	Assignment Sheet
	e04_assignsheet
	Online Instructor Resource Center 

	Prepared Exam (Chapter & App)
	 
	Online Instructor Resource Center 

	      Prepared Exam-Chap instruction
	e04_exam_chap_instruction
	

	      Prepared Exam-Chap solution
	e04_exam_chap_solution
	

	      Prepared Exam-Chap Data
	e04_exam_chap_data
	

	      Prepared Exam-Chap Annotated Sol.
	e04_exam_chap_annsolution
	

	      Prepared Exam-Chap Scorecard
	e04_exam_chap_scorecard
	

	      Prepared Exam-App instruction
	e04_cumexam_instruction
	 

	      Prepared Exam-App solution
	e04_cumexam_solution
	 

	      Prepared Exam-App Data
	e04_cumexam_data
	 

	      Prepared Exam-App Annotated Sol.
	e04_cumexam_annsolution
	 

	      Prepared Exam-App scorecard
	e04_cumexam_scorecard
	 

	File Guide
	e04_file_guide
	Online Instructor Resource Center 

	Instructor Resource Card
	e04_ircard
	Online Instructor Resource Center 

	Objective Map
	e04_objectivesmap
	Online Instructor Resource Center 

	Online Chapter Review
	e04_chapt_checklist
	Companion Website for Students

	Grader Project
	 
	 

	       Grader-instruction
	e04_grader_instruction
	Online Instructor Resource Center 

	       Grader-solution
	e04_grader_solution
	

	       Grader-data
	e04_grader_data
	

	       Grader-annoted. Solution
	e04_grader_annsolution
	 

	       Grader-scorecard
	e04_grader_scorecard
	 

	Additional Projects (Practice & Mid Level)
	 
	Online Instructor Resource Center 

	       Additional Proj-Practice instruction
	e04_p_addproject_instruction
	

	       Additional Proj- Practice solutions
	e04_p_addproject_solution
	

	       Additional Proj-Practice Data
	e04_p_addproject_data
	

	       Additional Proj-Practice Ann Sol.
	e04_p_addproject_annsolution
	

	       Additional Proj-Practice Scorecard
	e04_p_addproject_scorecard
	

	       Additional Proj-Mid Level instruction
	e04_ml_addproject_instruction
	 

	       Additional Proj-Mid Level solutions
	e04_ml_addproject_solution
	

	       Additional Proj-Mid Level Data
	e04_ml_addproject_data
	

	       Additional Proj-Mid Level Ann Sol.
	e04_ml_addproject_annsolution
	 

	       Additional Proj-Mid Level Scorecard
	[bookmark: _GoBack]e04_ml_addproject_scorecard
	 



CHAPTER OBJECTIVES 
When students have finished reading this chapter, they will be able to:

· Freeze rows and columns 
· Print large datasets 
· Design and create tables 
· Apply a table style
· Sort data 
· Filter data 
· Use structured references and a total row 
· Apply conditional formatting 
· Create a new rule


CHAPTER OVERVIEW
The students will learn how to work with large datasets and how to filter data or apply conditional formatting.
The major sections in this chapter are
Large Datasets. In this section, students will learn how to keep labels onscreen as they scroll through a large dataset. In addition, they will learn how to manage page breaks, print only a range instead of an entire worksheet, and print column labels at the top of each page of a large dataset.

Excel Tables. Although more complicated related data should be stored in a database management program, such as Access, students can maintain structured lists in Excel tables.
3.	Table Manipulation. In this section, students will learn how to sort records by text, numbers, and dates in a table. In addition, they will learn how to filter data based on conditions you set.

4.	Table Aggregation. In this section, students will learn how to insert structured references to build formulas within a table. In addition, they will learn how to add a row at the end of the table to display basic statistical calculations.

5.	Conditional Formatting. In this section, students will learn about the five conditional formatting categories and how to apply conditional formatting to a range of values based on a condition you set.


CLASS RUN-DOWN
1. Have students turn in Homework assignments.
2. Talk about chapter using discussion questions listed below. 
3. Use PowerPoint Presentation to help students understand chapter content.
4. Demonstrate Excel 2013 database possibilities and ways to work with the database tables for efficiency.
5. Run through Scripted Lectures for chapter. Give special attention to areas where students might be challenged.
6. Have students complete Capstone Exercise for Excel Chapter 4.
7. Use myitlab for in-class work or to go over homework.
8. Give students Homework Handout for next class period. 

LEARNING OBJECTIVES
At the end of this lesson students should be able to

· Freeze rows and columns 
· Print large datasets
· Understand table design 
· Create a table 
· Apply a table style 
· Sort data 
· Filter data 
· Use structured references and a total row 
· Apply conditional formatting 
· Create a new rule  
· Sort and filter using conditional formatting
KEY TERMS
Chapter X: Title	
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Color Scale–Formats different cells with different colors, assigning one color to the lowest group of values and another color to the highest group of values with gradient colors to other values. 
Conditional formatting–Applies special formatting to highlight or emphasize cells that meet certain conditions.
Data Bar–Applies a gradient or solid fill bar in which the width of the bar represents the current cell's value compared to other cells' values. 
Field–Each column is a field which is an individual piece of data, such as a last name.
Filtering–Process of specifying conditions to display only records that meet specific conditions.
Freezing–Keeps rows and/or columns visible onscreen at all times as you scroll a worksheet.
Highlight Cell Rules– Highlights cells with a fill color, font color, or border (such as Light Red Fill with Dark Red Text) if values are greater than, less than, between two values, equal to a value, or duplicate values; text that contains particular characters; or dates when a date meets a particular condition.
Icon Sets–Inserts an icon from an icon palette in each cell to indicate values compared to each other.
Page break–An indication of where data will start on another printed page.
Print area–Defines range of cells that will print.
Print order–Sequence in which pages print.
Record–Complete set of data for an entity which is represented as a row in a table.
Sorting–Process of arranging records in a table by the value in field(s) within a table. NOTE: Excel enables you to sort data on 64 different levels.
Structured reference–Tag or use of a table element (column/field heading) as a reference in a formula.
SUBTOTAL function–Calculates an aggregate for values in a range or database.
Table style–Controls the fill color of the header row, total row, columns, and records and borders in a table.
Table–Area in the worksheet containing rows and columns of related data formatted to enable data management and analysis.
Top/Bottom Rules–Formats cells with values in the top 10 items, top 10%, bottom 10 items, bottom 10%, above average, or below average. You can change the exact values to format the top or bottom items or percentages, such as top 5 or bottom 15%.
Total row–Appears as last row of a table to display summary statistics (e.g., Sum).
Unqualified reference–Use of column headings without row references in a formula.

DISCUSSION QUESTIONS
· What challenges are posed when working with large datasets?
· What are your “freeze” options and how will they help you?
· Why might you want to change the order of how sheets print when working with a large dataset?
· When there are duplicate records in a table with identical information, what should you do?
· Describe what “sort” will do in a table. Describe what “filter” will do in a table.
· What is a structured reference and how is it helpful?

WHEN USING SCRIPTED LECTURE IN CLASS, DEMONSTRATE HOW TO: 
· Freeze rows and columns
· Print large datasets
· Create a table
· Apply a table style
· Sort data
· Filter data
· Use structured references and a total row
· Apply conditional formatting
· Create a new rule
· Sort and filter using conditional formatting

CONNECTIONS PRACTICAL PROJECTS AND APPLICATIONS
· Download information from the census bureau and create a table and do analysis for a market research project.
· Use information available from a stock exchange and create a table to do analysis.
· Create a listing of students in your school and convert to a table to filter by major.
TEACHING NOTES
Large Datasets
It is important to learn how to keep labels onscreen when scrolling through a large dataset. In addition, students need to learn how to manage page breaks, print only a range instead of an entire worksheet, and print column labels at the top of each page of a large dataset.
A.	Freezing Rows and Columns
· Freezing Panes allows you to keep rows and/or columns visible onscreen at all times as you scroll a worksheet.
· Teaching Tips: Demo to students the three options when freezing: Freeze Panes, Freeze Top Row, Freeze First Column.
B.	Printing Large Datasets 
· For a large dataset, some columns and rows may print on several pages. Analyzing the data on individual printed pages is difficult when each page does not contain column and row labels.
· Preview (Page Layout view) and adjust settings before printing (Page Layout tab)
· Set and clear a print area which is the range of cells that will print.
· Teaching Tips: Another way to print part of a worksheet is to select the range you want to print. Click the File tab and click Print. Click the first arrow in the Settings section and select Print Selection.
· Teaching Tips: To identify where these automatic page breaks will occur, click Page Break Preview on the status bar or in the Workbook Views group on the View tab. In Page Break Preview, Excel displays watermarks, such as Page 1, indicating the area that will print on a specific page. Blue dashed lines indicate where the automatic page breaks occur, and solid blue lines indicate manual page breaks.
· Teaching Tips: When you print large datasets, it is helpful that every page contains descriptive column and row labels. When you click Print Titles in the Page Setup group on the Page Layout tab, Excel opens the Page Setup dialog box with the Sheet tab active so that you can select which row(s) and/or column(s) to repeat on each printout.
· Teaching Tips: Control print page order using the Page Setup box. Click the Sheet tab and select the desired Page order option.
Excel Tables
Although more complicated related data should be stored in a database management program, such as Access, it is possible to maintain structured lists in Excel tables.
A.	Designing and Creating Tables
· Although more complicated related data should be stored in a database management program, such as Access, you can maintain structured lists in Excel tables.
· It is important to learn table terminology and rules for structuring data.
· A table is the area in the worksheet containing rows and columns of related data formatted to enable data management and analysis.
· The fields are structured in columns which contain individual pieces of data, such as a last name or a customer ID.
· A record is a complete set of data for an entity which is represented as a row in a table.
· Guidelines of design include the following:
· Enter field (column) names on top row.
· Teaching Tips: Keep field names relatively short, descriptive, and unique.
· Format field names so that they stand out from the data.
· Enter data for each record on a row below the field names.
· Do not leave blank rows between records or between the field names and the first record.
· Delete any blank columns between fields in the dataset.
· Ensure that there is a unique field in each record, such as a transaction number or ID.
· Insert at least one blank row and one blank column between table and other data, such as the main titles, input area, or other tables.
· Teaching Tips: If possible, place separate tables on separate worksheets.
· There are two approaches to creating a table: (1) Convert existing data to a table or (2) Create table and add data later.
· Teaching Tips: You can also create a table by selecting a range, clicking the Quick Analysis button, clicking Tables in the Quick Analysis gallery, and then clicking Table. While Quick Analysis is efficient for tasks such as creating a chart, it may take more time to create a table because you have to select the entire range first. Some people find that it is faster to create a table from the Insert tab.
· Teaching Tips: To convert a table back to a range, click within the table range, click the Table Tools Design tab, click Convert to Range in the Tools group, and then click Yes in the message box asking, Do you want to convert the table to a normal range?
· To add a field (column), click in any data cell that will be to the right of the new field, click Home tab, click the Insert arrow in the Cells group.
· Teaching Tips: You can also delete a field if you no longer need any data for that particular field. Although deleting records and fields is easy, you must make sure not to delete data erroneously. If you accidentally delete data, click Undo immediately. To delete a field, do the following:
· Click a cell in the field that you want to delete.
· Click the Delete arrow in the Cells group on the Home tab.
· Select Delete Table Columns.
· Teaching Tips: To add a record, click a cell in the record below where you want the new record inserted, click Home tab, click the Insert arrow in the Cells group.
· Teaching Tips: To delete a record from the table, click a cell in the record that you want to delete, click the Home tab and click the Delete arrow in the Cells group. Select Delete Table Rows.
· Teaching Tips: To remove duplicate rows use Table Tools Design tab, Tools group, Remove Duplicates command.
· Teaching Tips: You can also click the Data tab and click Remove Duplicates in the Data Tools group to open the Remove Duplicates dialog box.

B.	Applying a Table Style
· The Table style controls the fill color of the header row, total row, columns, and records and borders in a table.
· Teaching Tips: Click Quick Styles in the Table Styles group to display the Table Styles gallery. To see how a table style will format your table using Live Preview, position the pointer over a style in the Table Styles gallery. After you identify a style you want, click it to apply it to the table.
Table Manipulation
To manage data it is important to learn how to sort records by text, numbers, and dates in a table. In addition, students will learn how to filter data based on conditions or criteria.
A.	Sorting Data
· Sorting is the process of arranging records in a table by the value in field(s) within a table. NOTE: Excel enables you to sort data on 64 different levels.
· Teaching Tips: Use the Sort dialog box Custom Sort button to sort multiple columns.
· Teaching Tips: Excel arranges data in defined sequences, such as alphabetical order. For example, days of the week are sorted alphabetically: Friday, Monday, Saturday, Sunday, Thursday, Tuesday, and Wednesday. You can create a custom sort sequence by using the Custom Lists dialog box. 
B.	Filtering Data
· Filtering is the process of specifying conditions to display only records that meet specific conditions.
· Teaching Tips: Often you will need to apply more than one filter to display the needed records. You can filter more than one field. Each additional filter is based on the current filtered data and further reduces a data subset. To apply multiple filters, click each field’s filter arrow and select the values to include in the filtered data results.
· Teaching Tips: Click the Filter Button check box in the Table Style Options group on the Design tab to display or hide the filter arrows. For a range of data instead of a table, click Filter in the Sort & Filter group on the Data tab to display or hide the filter arrows.
· Apply text, value, and date filters based on data in a particular field.
· Teaching Tips: Custom filter allows more complex filtering requirements. If you select options such as Greater Than or Before, Excel displays the Custom AutoFilter dialog box. You can also select Custom Filter from the menu to display the dialog box for more complex filtering needs.
· You can clear (remove) the filters from one or more fields to expand the dataset again. To remove only one filter and keep the other filters, click the filter arrow for the field from which you wish to clear the filter and select Clear Filter From.
Table Aggregation
The purpose of the Table Aggregation content is to learn how to insert structured references to build formulas within a table. In addition, students will learn how to add a row at the end of the table to display basic statistical calculations.

A.	Using Structured References and a Total Row
· Excel aids in quantitative analysis.
· Formulas for tables can use self-documenting built-in functionality that require less explanation.
· Structured reference is a tag or use of a table element (column/field heading) as a reference in a formula.
· Unqualified reference is the use of column headings without row references in a formula.
· Fully qualified reference is the structured formula that includes references such as table numbers and row numbers.
· Teaching Tips: When you build formulas within a table, you can use either unqualified or fully qualified structured references. If you need to use table data in a formula outside the table boundaries, you must use fully qualified structured references.
· Teaching Tips: Use Help for detailed explanations and examples of complex use of structured references.
· Total row appears as last row of a table to display summary statistics (e.g., sum).
· SUBTOTAL function calculates an aggregate for values in a range or database.
· Teaching Tips: If you filter the data and display the total row, the SUBTOTAL function’s 109 argument ensures that only the displayed data are summed; data for hidden rows are not calculated in the aggregate function.

Conditional Formatting
In this section, you will learn about the five conditional formatting categories and how to apply conditional formatting to a range of values based on a condition you set.

A.	Applying Conditional Formatting
· With conditional formatting, it is easier for the audience to understand a dataset better because it adds a visual element to the cells.
· Use Home tab, Styles group, Conditional Formatting button.
· Conditional formatting applies special formatting to highlight or emphasize cells that meet certain conditions.
· Teaching Tips: Do not overdo it! Do not apply conditional formatting to too many columns.
· Teaching Tips: When you select a range and click the Quick Analysis button, the Formatting options display in the Quick Analysis gallery. Position the mouse over a thumbnail to see how it will affect the selected range. You can also apply conditional formatting by clicking Conditional Formatting in the Styles group on the Home tab.
· Conditional formatting options include Highlight Cell Rules, Top/Bottom Rules, Data Bars, Color Scales, and Icon Sets.
· Highlight Cell Rules– Highlights cells with a fill color, font color, or border (such as Light Red Fill with Dark Red Text) if values are greater than, less than, between two values, equal to a value, or duplicate values; text that contains particular characters; or dates when a date meets a particular condition.
· Top/Bottom Rules–Formats cells with values in the top 10 items, top 10%, bottom 10 items, bottom 10%, above average, or below average. You can change the exact values to format the top or bottom items or percentages, such as top 5 or bottom 15%.
· Data Bar–Applies a gradient or solid fill bar in which the width of the bar represents the current cell's value compared to other cells' values. 
· Color Scale–Formats different cells with different colors, assigning one color to the lowest group of values and another color to the highest group of values with gradient colors to other values.
· Icon Sets–Inserts an icon from an icon palette in each cell to indicate values compared to each other.
· Teaching Tips: To clear conditional formatting from the entire worksheet, click Conditional Formatting in the Styles group on the Home tab, point to Clear Rules, and then select Clear Rules from Entire Sheet. To remove conditional formatting from a range of cells, select cells. Then click Conditional Formatting, point to Clear Rules, and then select Clear Rules from Selected Cells.
· Teaching Tips: You can sort and filter by conditional formatting. For example, if you applied the Highlight Cells Rules conditional formatting, you can sort the column by color so that all cells containing the highlight appear first or last. To do this, display the filter arrows, click the arrow for the conditionally formatted column you wish to sort, point to Sort by Color, and then click the fill color or No Fill in the Sort by Cell Color area. If you applied the Icon Sets conditional formatting, you can filter by icon.
B.	Creating a New Rule
· Conditional Formatting Rules Manager dialog box is used to edit and delete conditional formatting rules.
· Use the New Formatting Rule dialog box to define new conditional formatting rules.
· Teaching Tips: Use formula-based rule for complex conditional formatting; can refer to multiple columns.
ONLINE CHAPTER REVIEW
To find an online chapter review to help your students practice for tests, visit the Companion Web site at http://www.pearsonhighered.com/exploring/.
ADDITIONAL WEB RESOURCES
1. How to use Microsoft Excel data tables to analyze information in a database: http://support.microsoft.com/kb/282851
2. Freeze or lock rows and columns: http://office.microsoft.com/en-us/excel-help/freeze-or-lock-rows-and-columns-HP010342542.aspx
3. Overview of Excel tables: http://office.microsoft.com/en-us/excel-help/overview-of-excel-tables-HA010048546.aspx
4. Create or delete an Excel table in a worksheet: http://office.microsoft.com/en-us/excel-help/create-or-delete-an-excel-table-in-a-worksheet-HA010013764.aspx?CTT=3

PROJECTS AND EXERCISES
	
	Data file
	Save As

	Hands-On Exercise 1
	e04h1Reid
	e04h1Reid_LastFirst

	Hands-On Exercise 2
	e04h1Reid_LastFirst
	e04h2Reid_LastFirst

	Hands-On Exercise 3
	e04h2Reid_LastFirst
	e04h3Reid_LastFirst

	Hands-On Exercise 4
	e04h3Reid_LastFirst
	e04h4Reid_LastFirst

	Hands-On Exercise 5
	e04h4Reid_LastFirst
	e04h5Reid_LastFirst

	Practice Exercise 1
	e04p1Colors
e04p1Items
	e04p1Collection_LastFirst

	Practice Exercise 2
	e04p2Donate
	e04p2Donate_LastFirst

	Mid-Level Exercise 1
	e04m1Classes
	e04m1Classes_LastFirst

	Mid-Level Exercise 2
	e04m2FineArt
	e04m2FineArt_LastFirst

	Mid-Level Exercise 3 (collaboration)
	 Blank workbook
	e04m3PlayList_LastFirst.xlsx

	BYC  Research
	Blank workbook
	e04b2Flights_LastFirst.xlsx

	BYC  Disaster Recovery
	e04b3Populate.xlsx
	e04b3Populate_LastFirst.xlsx

	BYC  Soft Skills
	 Blank workbook
	e04b4Performance_LastFirst.xlsx

	Capstone
	e04c1Houses.xlsx
	e04c1Houses_LastFirst.xlsx



CHAPTER REVIEW/ANSWERS TO END OF CHAPTER MATERIAL

Key Terms Matching Answer Key

1. A Data bar (C) is a conditional format that displays horizontal gradient or solid fill indicating the cell’s relative value compared to other selected cells. p. 597
2. Sorting (L) is the process of listing records or text in a specific sequence, such as alphabetically by last name. p. 576
3. Filtering (E) is the process of specifying conditions to display only those records that meet those conditions. p. 578
4. Conditional formatting (B) is a set of rules that applies specific formatting to highlight or emphasize cells that meet specifications. p. 594
5. A Record (K) is a group of related fields representing one entity, such as data for one person, place, event, or concept. p. 565
6. Table style (P) is the rules that control the fill color of the header row, columns, and records in a table. p. 569
7. A Page break (H) is an indication of where data will start on another printed page. p. 558
8. A Total row (Q) is a table row that appears below the last row of records in an Excel table and displays summary or aggregate statistics, such as a sum or an average. p. 588
9. A Color scale (A) is a conditional format that displays a particular color based on the relative value of the cell contents to the other selected cells. p. 599
10. Print order (J) is the sequence in which the pages are printed. p. 560
11. A Structured reference (M) is a tag or use of a table element, such as a field label, as a reference in a formula. Field labels are enclosed in square brackets, such as [Amount] within the formula. p. 587
12. An Icon set (G) is a conditional format that displays an icon representing a value in the top third, quarter, or fifth based on values in the selected range. p. 598
13. A Print area (I) is the range of cells within a worksheet that will print. p. 559
14. The SUBTOTAL function (N) is a predefined formula that calculates an aggregate value, such as totals, for values in a range, a table, or a database. p. 588
15. A Field (D) is the smallest data element contained in a table, such as first name, last name, address, and phone number. p. 565
16. A Table (O) is a structure that organizes data in a series of records (rows), with each record made up of a number of fields (columns). p. 565
17. Freezing (F) is the process of keeping rows and/or columns visible onscreen at all times even when you scroll through a large dataset. p. 557
Multiple Choice Answer Key
1. You have a large dataset that will print on several pages. You want to ensure that related records print on the same page with column and row labels visible and that confidential information is not printed. You should apply all of the following page setup options except which one to accomplish this?
(d) Change the print page order.

2. You are working with a large worksheet. Your row headings are in column A. Which command(s) should be used to see the row headings and the distant information in columns X, Y, and Z?
(a) Freeze Panes command

3. Which statement is not a recommended guideline for designing and creating an Excel table?
(c) Leave one blank row between records in the table.

4. You have a list of all the employees in your organization. The list contains employee name, office, title, and salary. You want to list all employees in each office branch. The branches should be listed alphabetically, with the employee earning the highest salary listed first in each office. Which is true of your sort order?
(a) Branch office is the primary sort and should be in A to Z order.

5. You suspect a table has several identical records. What should you do?
(b) Use the Remove Duplicates command.

6. Which check box in the Table Style Options group enables you to apply different formatting to the records in a table?
(b) Banded Rows

7. Which date filter option enables you to specify criteria for selecting a range of dates, such as between 3/15/2016 and 7/15/2016?
(d) Between

8. You want to display a total row that identifies the oldest date in a field in your table. What function do you select from the list?
(c) Min

9. What type of conditional formatting displays horizontal colors in which the width of the bar indicates relative size compared to other values in the selected range?
(c) Data Bars

10. When you select the ______ rule type, the New Formatting Rule dialog box does not show the Format button.
(a) Format all cells based on their values
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